CrystalFaerie

Warning: Phishing site

33 posts in this topic

Okay, this is really weird. I just tried to click on the "Random Thoughts" thread and both times in a row, a warning message came up on my screen saying the page I'm trying to access is probably a phishing site. I've never seen this message before and in all my time on this site, this has never happened to me.

 

Anybody else had this happen? Any explanation?

 

I'm really confused  :blink:

4 people like this

Share this post


Link to post
Share on other sites

Yeah, it started happening to me awhile ago when I click on a topic (it even happened on this one.)

 

 

Wouldn't know why it's happening though. 

Share this post


Link to post
Share on other sites

I haven't had any problems like that, but I'm on my tablet

Share this post


Link to post
Share on other sites

Both Firefox and Avast blocked this specific thread, though nothing else that I've experienced so far.  I'd almost be willing to bet a wooden nickel that the donkey's rear who has been spamming this place the past few days had something to do with this.  When given the option in my browser, I reported to Google that this wasn't a threatening site.  What that's worth, I don't know.

 

Edit:  I'm getting it with various other threads now.  That's very annoying.  I do notice that when I click on a thread, in the address bar it takes me to a specific post in the thread, rather than to the main thread itself.  It's never done that before on this site.

Share this post


Link to post
Share on other sites

I'm getting it with the whole forum.  I reported the problem to Google, so hopefully they stop labeling it as a phishing site.

1 person likes this

Share this post


Link to post
Share on other sites

Hey Everybody,

     I have also received Google's red security page recently. I was able to contact Mike, he is aware of the issue, and he will ask Google to rescan the site (now that the spam threads are gone) sometime this week. He hopes that will resolve the issue. 

11 people like this

Share this post


Link to post
Share on other sites

I have a feeling there's a lot less activity on here lately, and its due to people being scared away by their browsers with the "reported site" warning... :(

1 person likes this

Share this post


Link to post
Share on other sites

I have a feeling there's a lot less activity on here lately, and its due to people being scared away by their browsers with the "reported site" warning... :(

 

Yep, I was gone for ages because I couldn't access the site. The warning popped up every few seconds and it was just impossible to navigate. Now I'm using Google Chrome and it's been okay so far...

Share this post


Link to post
Share on other sites

I still get the warnings when I first load the main site or the forums. Once I'm actually in the forums, I can navigate around fine without any warnings, but it's still annoying having to click past the warnings just to get in in the first place. Grrr...

 

Probably shouldn't complain too much, though...

 

 

xxx

4 people like this

Share this post


Link to post
Share on other sites

I've been unable to get on the site for the last few weeks due to this. If I clicked "ignore warning" it would still not allow me to visit the site. Discovered today that on Safari, you can go to "Preferences" then "Security" and then uncheck "Warn when visiting fraudulent website." The browser let me through after that.

Share this post


Link to post
Share on other sites

I am now getting a Malicious website warning on my tablet for every page I go to

Share this post


Link to post
Share on other sites

I am now getting a Malicious website warning on my tablet for every page I go to

 

This has been happening to me with my cellphone -- I'm pretty sure it's actually preventing me from being able to log in on my mobile browser.

Share this post


Link to post
Share on other sites

Hey Everybody,

 

An update: Still working on this. Very sorry for the inconvenience. 

 

Two things happened:

1. Spammers posted spammy threads (as they do). They admin team caught them (yay admins!), but not before Google's scanner robots saw them. That was the first flag.

 

2. The chat software (the chat bar at the bottom of the site) needs an update. Do people still use that, btw?

 

#1 has been solved. It's just convincing google. I'm working on #2 this week. Thanks for your patience, and hope you're all well!

9 people like this

Share this post


Link to post
Share on other sites

Hopefully after this is over, we'll have a full chat room again.

1 person likes this

Share this post


Link to post
Share on other sites

 

2. The chat software (the chat bar at the bottom of the site) needs an update. Do people still use that, btw?

 

I still use this 

Share this post


Link to post
Share on other sites

Is it just me or has the warning gone away?

 

Nope, it's gone for me, too.

 

xxx

2 people like this

Share this post


Link to post
Share on other sites

The site seems to be no longer broken.  Definite thanks and gratitude to Mike for fixing things.  It had become quite a chore to navigate around this place.

3 people like this

Share this post


Link to post
Share on other sites